[Forums] Can't do the Magblade but I got what is needed : (

Discussion in 'Bugs/Issues' started by Garth Jones, May 27, 2012.

  1. Garth Jones

    Garth Jones Member

    Anyone else having a problem with the Magblade? I'm past the level requirements, have what is needed but the system won't allow me to enter the blueprint details! I have tried refreshing, clearing cache, rebooting... still no go :(
  2. gods people

    gods people Active Member

    Sydney Missing Item(s)
    Level Unlock: Level 1720
    Crafting Cost: $16,000,000,000. what are you using to craft it.
  3. Garth Jones

    Garth Jones Member

    It won't open the window to allow me to enter anything : (
  4. The Protector

    The Protector Banned

    Very odd if you're the correct level and have what's needed.Very odd indeed.
  5. Garth Jones

    Garth Jones Member

    I think I've worked it out... I have yet to open the Sydney Turf War challenge as I have to 'speed chase 30 times' first, and that's the 3rd Job in Sydney...

Share This Page